2 příspěvky / 0 new
Poslední
jik
Obrázek uživatele jik
Offline
Naposledy viděn: 1 rok 3 měsíce zpět
Připojen: 19.09.2007 - 09:15
ies4linux: explodér a wineserver

Zdravím,
jsme nuceni používat MSIE. Na OS 10.3 bylo vše normální (nikdy jsem podrobněji nestudoval), zatímco u OS 11.0 se objevila zajímavá věc: Explodér po spuštění a přihlášení k jakémusi webu (IS Synergy) společně s procesem wineserver neustále užírá paměť, až sežere všechno a stroj vytuhne. Zajímavé je to, že procesy zůstanou živé i po ukončení a uzavření okna MSIE, stejně tak spotřeba paměti roste pořád. Když ustřelím IEXPLORE.EXE, tak wineserver zvýší zátěž cpu na 100% a ještě chvilku užírá dále, potom ale zpomalí/zpomaluje?/zastavuje?.
Platí pro ies4linux 2.0.5, MSIE 6.0 a wine-0.9.64_aka_1.0.rc3-2.1 (zřejmě původní instalační). Po instalaci wine-1.1.6-1.1 se to, zdá se, chová podobně, jen ta rychlost užírání se podstatně zmenšila. Kromě toho po zavření MSIE sice uvolní paměť, ale pořád žere cpu, což trvá, dokud IEXPLORE.EXE nezastřelím. Po zastřelení MSIE ale končí i wineserver.
Zatím jsem na ulimit nesáhl.

Obrázek uživatele JirkaZ
Offline
Naposledy viděn: 2 roky 7 měsíců zpět
Připojen: 17.10.2006 - 19:12
Nepostřehl jsem v textu

otázku, takže k volné debatě přidám svoji:

není dobré se zamyslet nad slovním spojením "jsme nuceni používat MSIE" a ještě spíš s tím něco dělat?

Já ten bazmek nepoužívám ani ve Windows (a to na nich jedu převážně).

JirkaZ

jik
Obrázek uživatele jik
Offline
Naposledy viděn: 1 rok 3 měsíce zpět
Připojen: 19.09.2007 - 09:15
Ona tam otázka skutečně

Ona tam otázka skutečně nebyla, ona je to napůl informace, když by do toho někdo naboural. Zatím toho o tom vím málo, ale co kdyby už to někdo potkal.
K té dobrovolnosti prohlížeče: Firma koupila 'skvělý IS' - Synergy. Koncepčně to vypadá velice dobře (přístup přes prohlížeč), realizace je však strašná - to opravdu nechodí na ničem jiném, než na MSIE.

Obrázek uživatele JirkaZ
Offline
Naposledy viděn: 2 roky 7 měsíců zpět
Připojen: 17.10.2006 - 19:12
Je to konkrétně

tohle? Pokud ano, zkusil jsem namátkou jeden z příkladů a zdá se, že to ve FF (3.0.3 pod Windows) normálně funguje...

Update: aha, ono to spíš bude tohle... No jo, tak tam je opravdu problém. Zkuste ale Konqueror s nastavenou identifikací jako IE - třeba se podaří.

JirkaZ

jik
Obrázek uživatele jik
Offline
Naposledy viděn: 1 rok 3 měsíce zpět
Připojen: 19.09.2007 - 09:15
Je to to první. Ono to

Je to to první. Ono to trochu chodí všude, ale jen trochu. Ono to fakticky nechodí úplně správně ani skrz MSIE na wine - proto jsem nakonec neměl odvahu to na OS(10.3) instalovat naší fakturantce.
Moc se mi to kdysi líbilo, ale jen do té doby, než jsem s tím musel začít pracovat. Kromě jiného to má hodně daleko i k ergonomii. Je to vítězství obchodního ducha nad zdravým rozumem. Velice před tím varuji. Dnes to považuji za vůbec nejhorší sw, jaký jsem kdy potkal.