2 příspěvky / 0 new
Poslední
Neznámý
Obrázek uživatele Neznámý
tiskárna netiskne

Zdravím všechny.
Nainstalovala jsem si SUSE, je to asi 14 dní. Tiskárna tiskla. Je to asi 4 dny, co jsem potřebovala něco vytisknout - tiskárna se tváří, že je vše v pořádku, tiskové úlohy jsou zařazeny k vytisknutí do fronty, ale nic se nevytiskne. Prohledala jsem celé fórum na portálu i na googlu, vyzkoušela jsem snad úplně vše, ale bez výsledku. Zkoušela jsem test v nastavení Yastu a hardwarově je v pořádku, protože mi vyjede papír - to je správně. Ostatní testy se nezdaří. Přes Nástroje - tisk - Správce tisku (http://localhost:631/) mi hlásí "404 Not found", takže tamtudy tiskárnu nenastavím. Tiskárna je v pořádku, protože před Win na tom samém PC jede. Žádné chybové hlášení se nekoná. Zkoušela jsem i přeinstalovat systém, ale nepomohlo.
Mám tiskárnu HP940c připojená přes USB - podporovaná je a SUSE 10.2.
Ví někdo, čím to může být?
Díky Ira

Obrázek uživatele JirkaZ
Offline
Naposledy viděn: 2 roky 11 měsíců zpět
Připojen: 17.10.2006 - 19:12
Máte nainstalovaný CUPS

včetně jeho konfigurace? CUPS je tiskový server a vede na něj právě ten link http://localhost:631 - pokud je nefunkční, tipoval bych to právě na jeho absenci či nějakou nekorektnost...

Zkuste tiskárnu nainstalovat v Ovládacím centru KDE, pokud KDE používáte (Administrátorský režim - tlačítko v příslušném okně dole - při zmenšeném okně nebývá vidět). Je to s průvodcem a více zautomatizované než přes YAST; mám dokonce dojem, že to odhalí nepřítomný či nefunkční CUPS.

JirkaZ

Obrázek uživatele JirkaZ
Offline
Naposledy viděn: 2 roky 11 měsíců zpět
Připojen: 17.10.2006 - 19:12
Tak se tedy podívejte

na stav instalace CUPSu (v YASTu, Smartu apod.), případně ho zkuste stejným nástrojem přeinstalovat. Tuším, že se mi kdysi dávno nějaký podobný problém s CUPSem stal.

JirkaZ

Obrázek uživatele JirkaZ
Offline
Naposledy viděn: 2 roky 11 měsíců zpět
Připojen: 17.10.2006 - 19:12
Kvůli nefunkční tiskárně

smazat systém, tím spíš, když je to otázka nastavení? To tedy fakt nemáte trpělivost...

Zkuste existující tiskárnu osdstranit (myslím její instalaci v SUSE, ne přístroj ;-) ) a přes Ovládací centrum KDE nainstalovat znova.

Ještě předtím zkuste v konzoli coby root spustit příkaz service cups restart - co to udělá?

A co http://localhost:631 - už funguje? Případně zkuste odkaz http://localhost:631/admin

JirkaZ

Obrázek uživatele JirkaZ
Offline
Naposledy viděn: 2 roky 11 měsíců zpět
Připojen: 17.10.2006 - 19:12
Balíček cups-client

máte nainstalovaný? Takhle vypadá moje instalace CUPSu a věcí s ním souvisejících.

Zkuste případně (v tomto pořadí): odinstalovat tiskárnu (resp. všechny, je-li jich víc), odinstalovat přes Smart CUPS a související balíčky (viz screenshot), smazat jako root /etc/cups, znovu nainstalovat CUPS a nastavit tiskárnu přes Ovládací centrum KDE. Za vyzkoušení stojí i downgrade CUPSu na předchozí verzi (nejlépe opět přes Smart).

JirkaZ

Obrázek uživatele JirkaZ
Offline
Naposledy viděn: 2 roky 11 měsíců zpět
Připojen: 17.10.2006 - 19:12
Pořád nepíšete

o balíčku cups-client, přestože jsem se na něj ptal a je i na screenshotu... Taky netuším, zda jste po odinstalování CUPSu smazala (v nějakém správci souborů) popisovanou složku /etc/cups. Po instalaci CUPSu bude asi nutný jeho restart, resp. restart démona - viz v konzoli výše.

JirkaZ

Obrázek uživatele JirkaZ
Offline
Naposledy viděn: 2 roky 11 měsíců zpět
Připojen: 17.10.2006 - 19:12
Nepodceňujte se,

pomáhal jsem Vám hlavně právě proto, že jste se snažila sama, nejste úplný laik (to je vidět z reakcí a popisů) a v kombinaci s tím jste žena. To se málokdy vidí...

Kdybyste začala "volat o pomoc" a nebyla vidět žádná vlastní snaha, odpálkoval bych Vás velmi rychle - to nakonec můžete vidět v mých jiných příspěvcích...

JirkaZ

Obrázek uživatele IrenaS
Offline
Naposledy viděn: 10 let 9 měsíců zpět
Připojen: 23.08.2007 - 08:07
znova to samé

Hned, jak vyšlo nové SUSE 10.3, tak jsem ho nainstalovala. Musím vývojáře pochválit - je rychlejší, některé chyby už jsou odstraněny.
Ale ten problém s tiskárnou, který jsem měla v červenci, objevil se zase. Úplně stejný. Udělala jsem skoro to samé, co tenkrát (nesmazala jsem úplně všechny soubory v /etc/cups). Zase funguje - tiskne. Ale mám silný dojem, že tiskárna přestala fungovat po upgradu některých souborů. To znamená po aktualizaci.
Moje rada asi zní - pokud něco funguje - nechte to tak, jak to je. Nedělejte aktualizaci ani upgrade.
Zdraví
Ira
PS: Pane JirkoZ - vaše pochvala mě těší - ani možná nevíte jak. Pořád si myslím, že toho o Linuxu vím velmi málo. Je tolik věcí, co ještě nevím . . .