2 příspěvky / 0 new
Poslední
Obrázek uživatele Ales Ulrych
Offline
Naposledy viděn: 3 roky 10 měsíců zpět
Připojen: 09.01.2015 - 06:41
Problém s namapováním disků + přehrání videa synology

OpenSuse jsem si nainstaloval 64bit variantě, prostředí Xfce, které je nejpodobnější Windows, na který je přítelkyně zvyklá. KDE jsem zkoušel také, ale je to moc velký skok. Update: asi se k KDE vrátím, našel jsem návod jak ho upravit, snad se bude více podobat tomu, na má drahá zná. :) Několik problémů s Xfce (se Skype, který potřeboval Pulseaudio, aby mi přehrával a nahrával) jsem rozchodil, ale jiné se mi nedaří.

Mám na NAS disku Synology nasdílená videa, které chci přimontovat do Opensuse xfce, aby při každém spuštění byly automaticky vidět. Přístup k disku Synology je chráněn heslem. Uživ. jméno je Ales, heslo pro příkad třeba xxx. Nejprv síť nic nenašla, po vypnutí firewalu už NAS disk Synology je vidět. Po naklikání na něj to chce uživatele a heslo a zda si to má zapamatovat. Dal jsem vždy pamatovat, pak heslo na nějakou klíčenku a disk se namapoval přes AFP. Všechny filmy vidím, ale nepřehraju je. Po přečtení různých diskuzí jsem namapoval disk i přes smb, ale stejný problém. Četl jsem diskuze, doinstaloval jsem tedy kodeky odsud: http://opensuse-guide.org/codecs.php, stále stejný problém. Tak jsem zkusil nainstalovat VLC odsud: http://www.videolan.org/vlc/download-suse.html a ten mi je nepřehraje též.

Níže posílám chyby.

připojeno přes afp://ales@DiskStationn.local/video/

Video:

Nějaký program vyžaduje k této operaci přídavý zásuvný modul
Je vyžadován následující zásuvný modul:
Zdroj protokolu AFP

Chcete vyhledat tento soubor? Po kliknutí na vyhledat to nic nenajde.

Videolan VLC:

No suitable decoder module:
VLC does not support the audio or video format "mp4v". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mp4a". Unfortunately there is no way for you to fix this.

připojeno přes smb://diskstationn/video/

Video:

Nějaký program vyžaduje k této operaci přídavý zásuvný modul
Je vyžadován následující zásuvný modul:
Zdroj protokolu SMB
Chcete vyhledat tento soubor? Po kliknutí na vyhledat to nic nenajde

Videolan VLC:

No suitable decoder module:
VLC does not support the audio or video format "mp4v". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "mp4a". Unfortunately there is no way for you to fix this.

Ovšem pokud video soubor zkopíruji do složky /home/darina/Videa/, program Videa to normálně přehraje, VLC ale nikoliv. VLC stále hlásí chybu s kodekem, ale nechápu proč.

Můžete mi prosím někdo poradit, jak jinak namapovat video ze Synology, aby šlo přehrát rovnou a nemusel jsem každé video kopírovat na místní složky. Jak to namapovani zautomatizovat?

Je toho víc, co sčím bych chtěl poradit, ale tímto přehráváním filmů z NAS bych začal. :)

Díky všem moc za pomoc

Aleš

Distribuce: 
Obrázek uživatele ferri
Offline
Naposledy viděn: 1 rok 6 měsíců zpět
Připojen: 02.10.2012 - 21:37
re: Packman

Je v systéme doplnený Packman repozitár?
http://opensuse-guide.org/repositories.php
http://www.opensuse.cz/pruvodce-11-softwarove-repozitare

Prehravac vlc je lepsie instalovat z tohto repozitára, lebo si automaticky dotiahne potrebné závislosti so sebou. Potrebný je taktiež balíček vlc-codecs + závislosti.

openSUSE Leap 42.2 KDE

Obrázek uživatele Ales Ulrych
Offline
Naposledy viděn: 3 roky 10 měsíců zpět
Připojen: 09.01.2015 - 06:41
VLC

Díky, pro jistotu jsem provedl formát a novou instalaci, přidal repozitáře a VLC už filmy přehrává. Bohužel pouze z lokálního disku (musím zkopírovat z namapovaného na lokál), když zkusím přehrát z namapovaného, hodí chybu: "VLC is unable to open the mrl".

Nicméně jsem už přišel nato, jak namapovat disk, aby mi přehrávání fungovalo přes příkazovou řádku jako root: "mount -t cifs //192.168.2.151/video /home/ales/Video -o username=Ales,password=xxxx,uid=1000,gid=100"

Jen bych potřeboval poradit, jak to zautomatizovat, aby se mi namapoval s root oprávněním už při startu systému.

Aleš Ulrych

Obrázek uživatele ferri
Offline
Naposledy viděn: 1 rok 6 měsíců zpět
Připojen: 02.10.2012 - 21:37
re: VLC

openSUSE Leap 42.2 KDE

Obrázek uživatele Ales Ulrych
Offline
Naposledy viděn: 3 roky 10 měsíců zpět
Připojen: 09.01.2015 - 06:41
Autofs

Tak už třetí noc se s tím trápím, našel jsem toto fórum, dle kterého jsme to celé nastavil: https://forums.opensuse.org/showthread.php/492495-Autofs-CIFS

Trvalo mi, než jsem pochopil jak to funguje, a vždy když jsem si už myslel, že to musí fungovat, výsledek žádný. Stále je namapovaná složka prázdná.

Pokud použiji manuální namapování, funguje to bez bez problémů.

mount -t cifs //Diskstationn/video /home/darina/Videa -o username=Ales,password=mojeheslo,uid=1000,gid=100

První problém byl, že to manuální namapování mi fungovalo jen s IP adresou, s názvem NAS ne, ale to jsem vyřešil přidáním názvu k IP adrese v hosts, poté už fungovalo výše uvedené spojení. Název jsem potřeboval kvůli výše uvedené diskuzi, pokud jsem ji pochopil správně.

Když to vše nyní spustím a zkontroluji si proces autofs, vidím tuto chybu: Local domain name not set
A zkrz ni se dál nedokážu dostat. Myslím, že proto mi to nefunguje, ale nevím, jak z toho ven. Celý výpis je zde:

autofs.service - Automounts filesystems on demand
Loaded: loaded (/usr/lib/systemd/system/autofs.service; enabled)
Active: active (running) since Sun 2015-01-11 09:05:30 CET; 3min 38s ago
Docs: man:automount(8)
man:autofs(5)
Process: 1383 ExecStart=/usr/sbin/automount ${AUTOFS_OPTIONS} -p /var/run/automount.pid (code=exited, status=0/SUCCESS)
Main PID: 1396 (automount)
CGroup: /system.slice/autofs.service
`-1396 /usr/sbin/automount -p /var/run/automount.pid

Jan 11 09:05:30 linux-yw6t automount[1396]: lookup_init:139: lookup(yp): map auto.master: Local domain name not set
Jan 11 09:05:30 linux-yw6t automount[1396]: [1B blob data]
Jan 11 09:05:30 linux-yw6t automount[1396]: [1B blob data]
Jan 11 09:05:30 linux-yw6t automount[1396]: [1B blob data]

Nic, co by bylo špatně v auto.master jsem nenašel, vždyť tam je přidání pouze jednoho řádku
co a kam se má namapovat. :(
Dokážete mi prosím poradit, proč mi to nefunguje?

Zde posílám pro zkotrolování mnou upravené soubory. https://www.dropbox.com/sh/d1zat44e8otue0p/AABWztMoyAOgf9U3uo5jHJD2a?dl=0

Díky moc za pomoc, už si fakt nevím rady.

Aleš

Aleš Ulrych

Obrázek uživatele ferri
Offline
Naposledy viděn: 1 rok 6 měsíců zpět
Připojen: 02.10.2012 - 21:37
re: Autofs

Osobne poradiť neviem.
Ale asi bude lepšie predniesť tento popis problému do už spomenutej rozbehnutej diskusie
https://forums.opensuse.org/showthread.php/492495-Autofs-CIFS

openSUSE Leap 42.2 KDE

Obrázek uživatele Ales Ulrych
Offline
Naposledy viděn: 3 roky 10 měsíců zpět
Připojen: 09.01.2015 - 06:41
re: Autofs

No, se svojí neangličtinou to nebude nic lehkého. :( Moje angličtina je pouze přes translator. :(

Podíval jste se na přiložené soubory, zda mi tam něco neuniklo?

Ještě jsem zkoušel do auto.cifs tam dát toto:

home/darina/Videa -fstype=cifs,nounix,noexec,username=Ales,password=mojeheslo,uid=1000,gid=100 ://Diskstationn/video

bohužel se stejným výsledkem

Doufal jsem, že to je jen nějaká blbost, na kterou nemůžu přijít. Nicméně díky za snahu.

Aleš Ulrych

Obrázek uživatele PavelH
Offline
Naposledy viděn: 3 roky 2 měsíce zpět
Připojen: 20.01.2013 - 10:05
local domain not set

Chybové hlášení "local domain name not set" znamená, že není nastaveno jméno počítače.
Zkoušel jsi jej nastavit příkazem: hostname jmeno_tveho_PC ?

Obrázek uživatele Ales Ulrych
Offline
Naposledy viděn: 3 roky 10 měsíců zpět
Připojen: 09.01.2015 - 06:41
to: PavelH

Myslíš v terminálu? Dát příkaz hostname a pak aktuální jméno PC, který mi Opensuse vygeneroval při instalaci? Nebo cokoliv jiného a tím ho přejmenuju? Protože, když se podívám na nastavení sítě, jméno PC (nějaké Linux a pár čísel) vidím. Přesně nevím, protože nyní jsem na Windows. V noci vyzkouším. Kéž by to byla jen takováto blbost.

Aleš Ulrych

Obrázek uživatele PavelH
Offline
Naposledy viděn: 3 roky 2 měsíce zpět
Připojen: 20.01.2013 - 10:05
hostname

Ano, měl jsem na mysli zapsat hostname v terminálu jako root.
Ale pokud vidíš v Yastu v nastavení sítě, že tam jméno je, tak to nepomůže.
Ve vedlejší kolonce (vedle jména počítače) je jméno domény a to by mělo být také vyplněno.

Obrázek uživatele Ales Ulrych
Offline
Naposledy viděn: 3 roky 10 měsíců zpět
Připojen: 09.01.2015 - 06:41
hostname

Jaká doména? Nejsem součástí domény. Mám PC připojený k modemu, stejně jako NAS Synology. Modem je DHCP server, který rozděluje IP adresy. U synology mám pevnou IP adresu a mám nastavený sdílený adresář, který si ve Windows normálně namountuju, v Ubuntu a jeho klonech také bez problému (tam zas mám jiné problémy - vypadávání netu, nefunkční 5.1 zvuk, proto jsem nyní na Opensuse), kde zas se mi nedaří taková blbost, jako přehrávání filmů z NAS. Namapovat přes SMB to jde lehce, ale bohužel už to filmy nepřehraje. Jak jsem už psal, musím film zkopírovat z NAS na lokál (to lze bez problémů) a pak to přehrát jde. Ale to není řešení. Funkční namapování přes terminál umím už také, ale aby to bylo funkční a automatické při startu systému se mi nedaří. Jak je už vidět, síťová složka je chráněná jménem a heslem.

Aleš Ulrych

Obrázek uživatele PavelH
Offline
Naposledy viděn: 3 roky 2 měsíce zpět
Připojen: 20.01.2013 - 10:05
auto.master

Ještě jsem se díval do diskuze na: https://forums.opensuse.org/showthread.php/492495-Autofs-CIFS

Podle příspěvku z 8-Dec-2013 označeného SOLVED (tj. že bylo vyřešeno) má být v souboru auto.master pouze řádek s připojením ( /home/darina/Videa /etc/auto.cifs –timeout=6 ), ale ty tam máš navíc i řádek +auto.master.
Nevím, jestli to bude řešení. Jen postřeh.

Obrázek uživatele Ales Ulrych
Offline
Naposledy viděn: 3 roky 10 měsíců zpět
Připojen: 09.01.2015 - 06:41
auto.master

Zkusil jsem dát před to komentář, chyba ohledně domény zmizí, namapovaná složka je bohužel stále prázdná. Zkusil jsem i příkaz zjednodušit, abych vzkoušel vyloženě funkčnost aut. namapování, ale ani tento zápis nefunguje. Nevím, kde může být chyba.

obsah auto.master:
+auto.master
/home/darina/Videa /etc/auto.cifs --timeout=60

obsah auto.cifs:
Diskstationn -fstype=cifs,nounix,noexec,username=Ales,password=mojeheslo,uid=1000,gid=100 ://Diskstationn/video

A ani toto neprošlo, stále je složka /home/darina/Videa prázdná. :(

Přitom tento zápis pro ruční namapování funguje krásně:
mount -t cifs //Diskstationn/video /home/darina/Videa -o username=Ales,password=mojeheslo,uid=1000,gid=100

Nějaký nápad, proč to nefunguje, kde mám v zápisu chybu?

Aleš Ulrych

Obrázek uživatele Ales Ulrych
Offline
Naposledy viděn: 3 roky 10 měsíců zpět
Připojen: 09.01.2015 - 06:41
Autofs

Právě jsem to vyřešil namountováním přes fstab. :)
//Diskstationn/video /home/darina/Videa cifs username=Ales,password=mojeheslo,_netdev 0 0

Aleš Ulrych