2 příspěvky / 0 new
Poslední
Obrázek uživatele buty
Offline
Naposledy viděn: 10 let 8 měsíců zpět
Připojen: 31.03.2008 - 14:10
Problém s javou v prohlížeči

Zdravím

už nějakou dobu se potýkám s problémem, a to že mi nefunguje java ve Firefoxu 3.
Mám naistalováno Opensuse 11.0 X86_64 bit.Hledal jsem různě na fórech ale nic co by fungovalo jsem nenašel.Také jsem nikde nenašel plugin pro 64 bitovou verzi.Uvítal bych každou dobrou radu nebo návod jak na to.

Obrázek uživatele johnnycage
Offline
Naposledy viděn: 8 let 11 měsíců zpět
Připojen: 09.07.2007 - 15:28
tu si stiahni javu pre

OS: Debian Testing 64bit, Kernel 2.6.38, GNOME 2.30.2
NB: Lenovo G550, Intel Pentium Dual-Core T4200 2.0GHz, RAM 3GB 1066MHz, WD 320GB, Intel GMA X4500 256MB

Obrázek uživatele buty
Offline
Naposledy viděn: 10 let 8 měsíců zpět
Připojen: 31.03.2008 - 14:10
zadna zmena

vyzkošel jsem ale situace je stejná a nic se nezměnilo ..

Obrázek uživatele johnnycage
Offline
Naposledy viděn: 8 let 11 měsíců zpět
Připojen: 09.07.2007 - 15:28
ked si spustis firefox cez

ked si spustis firefox cez konzolu a otvoris si stranku, ktora obsahuje javu, nevypise ti nejaku chybu v konzole? ze chyba nejaky subor, alebo nieco?

OS: Debian Testing 64bit, Kernel 2.6.38, GNOME 2.30.2
NB: Lenovo G550, Intel Pentium Dual-Core T4200 2.0GHz, RAM 3GB 1066MHz, WD 320GB, Intel GMA X4500 256MB

Obrázek uživatele buty
Offline
Naposledy viděn: 10 let 8 měsíců zpět
Připojen: 31.03.2008 - 14:10
nejsem ještě v linuxu tak

nejsem ještě v linuxu tak zběhlý, mohl bys mi vysvětlit jak to myslíš?
Spustím konzoli,pak napíši firefox nebo nějak jinak ??

Obrázek uživatele johnnycage
Offline
Naposledy viděn: 8 let 11 měsíců zpět
Připojen: 09.07.2007 - 15:28
otvoris si nejaky

otvoris si nejaky terminalovy program, napr. konsole, alebo gnome-terminal a napises firefox. Mal by sa ti spustit firefox, ale v terminale zostane vypis, co sa prave s programom deje. Potom das nacitat nejaku stranku, ktora obsahuje javu, teda kde je treba ten java plugin a v terminale uvidis, co sa deje, ci to nevypise nejaku hlasku, napr. java module error, alebo nieco na ten sposob

OS: Debian Testing 64bit, Kernel 2.6.38, GNOME 2.30.2
NB: Lenovo G550, Intel Pentium Dual-Core T4200 2.0GHz, RAM 3GB 1066MHz, WD 320GB, Intel GMA X4500 256MB

Obrázek uživatele buty
Offline
Naposledy viděn: 10 let 8 měsíců zpět
Připojen: 31.03.2008 - 14:10
vse jsem udelal ale spustil

vse jsem udelal ale spustil se jen firefox a tim vse skoncilo,kdyz jsem nacetl nejakou s tranku s javou tak to v konzoli nic nevypsalo.. tak nevim

Obrázek uživatele johnnycage
Offline
Naposledy viděn: 8 let 11 měsíců zpět
Připojen: 09.07.2007 - 15:28
robi ti to len vo firefoxe,

robi ti to len vo firefoxe, alebo aj v ostatnych prehliadacoch, napr. opera, seamonkey, konqueror?

OS: Debian Testing 64bit, Kernel 2.6.38, GNOME 2.30.2
NB: Lenovo G550, Intel Pentium Dual-Core T4200 2.0GHz, RAM 3GB 1066MHz, WD 320GB, Intel GMA X4500 256MB

Obrázek uživatele buty
Offline
Naposledy viděn: 10 let 8 měsíců zpět
Připojen: 31.03.2008 - 14:10
mam problem jen v opeře a

mam problem jen v opeře a ve firefoxu, konqueror si javu najde sam..

Obrázek uživatele johnnycage
Offline
Naposledy viděn: 8 let 11 měsíců zpět
Připojen: 09.07.2007 - 15:28
a ked si otvoris stranku,

a ked si otvoris stranku, kde je treba java, vypise ti aj, ze "Pro zobrazeni veskereho obsahu na strance jsou vyzadovany dodatecne zasuvne moduly"? ... skus este kuknut do nastaveni firefoxu upravy->predvolby->obsah, ci tam mas povolenu javu a java skripty. Dalej sa kukni do /usr/lib/browser-plugins, ci tam nemas symbolicky link @javaplugin.so

OS: Debian Testing 64bit, Kernel 2.6.38, GNOME 2.30.2
NB: Lenovo G550, Intel Pentium Dual-Core T4200 2.0GHz, RAM 3GB 1066MHz, WD 320GB, Intel GMA X4500 256MB

Obrázek uživatele buty
Offline
Naposledy viděn: 10 let 8 měsíců zpět
Připojen: 31.03.2008 - 14:10
ano když spustim stránku s

ano když spustim stránku s javou, tak mi prohlížeč vypíše že pro zobrazení správného obsahu stránky je vyžadován chybějící zásuvný modul,když dám vyhledat tak stejně nic nenajde a objeví se nabídka nainstalovat ručně.V prohlížeči mám javu a java scripty povoleny.Díval jsem se do toho adresáře /usr/lib/browser-plugins a link tam nebyl,zkusil jsem ho tam i udělat a nic...

Obrázek uživatele johnnycage
Offline
Naposledy viděn: 8 let 11 měsíců zpět
Připojen: 09.07.2007 - 15:28
ja som skusal prezmenu ten

ja som skusal prezmenu ten subor vymazat a robilo mi to to iste, co tebe ... s tym linkom to je trochu zlozitejsie a sice: ten link @javaplugin.so sa vo vnutri odkazuje na /etc/alternatives/javaplugin ... javaplugin je tiez odkaz, ktory sa odkazuje zase na /usr/lib/jvm/java-1.6.0-sun-1.6.0.u7/jre/plugin/i386/ns7/libjavaplugin_oji.so co je konecny subor. Javu mas teda nainstalovanu? Ak ano, tym padom by ti chybali len tie linky, ktore sa odkazuju na subor libjavaplugin_oji.so

OS: Debian Testing 64bit, Kernel 2.6.38, GNOME 2.30.2
NB: Lenovo G550, Intel Pentium Dual-Core T4200 2.0GHz, RAM 3GB 1066MHz, WD 320GB, Intel GMA X4500 256MB

Obrázek uživatele buty
Offline
Naposledy viděn: 10 let 8 měsíců zpět
Připojen: 31.03.2008 - 14:10
Když jsem si pročítal

Když jsem si pročítal různé návody na stránkách Javy a různých diskuzích tak tam bylo že se má vytvořit symbolický link v adresáři mozila/plugins a u mě se odkazuje na /usr/lib/jvm/jre-1.5.0-sun/plugin/i386/ns7/libjavaplugin_oji.so

Obrázek uživatele johnnycage
Offline
Naposledy viděn: 8 let 11 měsíců zpět
Připojen: 09.07.2007 - 15:28
takze, vymazal som z

takze, vymazal som z /usr/lib/browser-plugins subor @javaplugin, pri spusteni firefoxu mi vypisuje, ze chyba ten a ten plugin, takze som na tom ako ty. Nasiel som si, kde sa nachadza subor libjavaplugin_oji.so, konkretne u mna v /usr/lib/jvm/jre-1.5.0-sun/plugin/i386/ns7/libjavaplugin_oji.so, cez konzolu som sa dostal do adresara /home/meno_domovskeho_adresara/.mozilla/plugins a tam som vytvoril ten link takto:

ln -s /usr/lib/jvm/jre-1.5.0-sun/plugin/i386/ns7/libjavaplugin_oji.so

... tie dva riadky maju byt akoze jeden: ln -s /usr/...

v adresare .mozilla sa mi vytvoril subor (teda link) s nazvom @libjavaplugin_oji.so, potom som spustil firefox a java ide

OS: Debian Testing 64bit, Kernel 2.6.38, GNOME 2.30.2
NB: Lenovo G550, Intel Pentium Dual-Core T4200 2.0GHz, RAM 3GB 1066MHz, WD 320GB, Intel GMA X4500 256MB

Obrázek uživatele buty
Offline
Naposledy viděn: 10 let 8 měsíců zpět
Připojen: 31.03.2008 - 14:10
nikde nemohu najít ten

nikde nemohu najít ten adreář plugin. v .mozilla/ mám jen eclipse,extensions,firefox.
Zkusil jsem vytvořit adresář plugins v ./mozilla a pak jsem v něm udělal symb. link, ale nic se nezměnilo. buď to dělám špatně nebo někde jinde..