1 příspěvek / 0 new
Poslední
Obrázek uživatele rabas
Offline
Naposledy viděn: 11 let 4 měsíce zpět
Připojen: 01.08.2007 - 17:39
OpenOffice - chyba vstupu výstupu

Dobrý den,
po instalaci SLED 10.1 se objevil problém s ukládáním souborů z OpenOffice na síťové disky (Novell OES 1 SP 1, NetWare 6.5 SP 4 a SLES 9). Hlásí to chybu vstupu/výstupu.
Soubor se vytvoří a má nulovou velikost.
Při ukládání na lokální disk je vše v pořádku.
V SLED 10.0 tento problém nebyl.
Zkoušel jsem to na několika stanicích v síti, ale výsledek je všude stejný.
Verzí OpenOffice by to být nemělo. Zkusil jsem nainstalovat starší verzi OpenOffice ze SLED 10.0 a problém byl stejný.
Novell klienta mám 1.2, stejnou verzi jsem měl i na SLED 10.0 a problém nebyl.

Nejnovější updaty jsem dnes nainstaloval a problém přetrvává.

Jen tak pro zajímavost, podobný problém se vyskytuje u gedit v SLED 10.0 i v SLED 10.1. Ale rozdíl je v tom, že to hlásí chybu např.:

Nemohu uložit soubor "/home/honza/H/pokus22"
Soubor nenalezen

a to s každým druhým uložením: první uložení v pořádku, druhé uložení s chybou atd. pořád dokola.
Na lokální disk se ukládá bez problémů.

Prosím, jaký je Váš názor, kde by mohl být problém?

Jan Rabas

Obrázek uživatele JirkaZ
Offline
Naposledy viděn: 4 roky 1 týden zpět
Připojen: 17.10.2006 - 19:12
Pokud vím, tak OOo

měl s ukládáním na síťové disky problémy - a to spíš náhodného a nevyzpytatelného charakteru. Probíralo se to dost rozsáhle na konferenci OOo nebo na fóru (teď nevím), zkuste projít archiv konference nebo to fórum.

JirkaZ

Obrázek uživatele rabas
Offline
Naposledy viděn: 11 let 4 měsíce zpět
Připojen: 01.08.2007 - 17:39
Děkuji, vyřešeno

Moc děkuji za odpověď.
Jako už se mi stalo víckrát, sotva jsem napsal po pár týdnech konečně do fóra, našel jsem za chvíli řešení. Ale stále lepší, než to nevyřešit vůbec. ;-)

V tomto případě nejde vyloženě o chybu, ale o nastavení - řešení popisuju v druhém komentáři.

Jan Rabas

Jan Rabas

Obrázek uživatele rabas
Offline
Naposledy viděn: 11 let 4 měsíce zpět
Připojen: 01.08.2007 - 17:39
OpenOffice - chyba vstupu výstupu - vyřešeno

Dobrý den,
děkuji, mám to vyřešeno. Několik týdnů hledám řešení, a když konečně napíšu do fóra, tak ho za hodinu najdu. :-)
Našel jsem řešení na
http://ubuntuforums.org/showthread.php?t=332043

Sice se jedná o Ubuntu, ale až na rozdíly v cestě je to stejná věc.

Řešení (cesta už je upravená pro SUSE):

V souboru
/usr/lib/ooo-2.0/program/soffice

zakomentovat řádky:
SAL_ENABLE_FILE_LOCKING=1
export SAL_ENABLE_FILE_LOCKING

Nad tím je komentář: # file locking now enabled by default
Tím se to vysvětluje. Nejde tedy o chybu, ale o nastavení.

Nyní ukládání na síťové disky funguje bez problémů.
Týká se to obecně síťových disků nezávisle na tom, jaký je na tom síťovém disku souborový systém.

Poznámka: Mám vyzkoušeno konkrétně na SLED 10.1, ale asi to bude stejné i u openSUSE a SLES, pokud se tam stejná věc vyskytne.

Jan Rabas

Jan Rabas