0 příspěvků / 0 new
Obrázek uživatele LiborA
Offline
Naposledy viděn: 6 let 5 měsíců zpět
Připojen: 09.07.2006 - 18:00
Body: 0
chyba "Cannot init AGP"

Zdravím,

nemohu stále vyřešit jeden problém. Po installaci ATi driverů mi velmi často skončí náběh systému v "černu" (už jsem se to zde jednou snažil řešit - http://www.suseportal.cz/forum/ati-hd2400-agp-po-instalaci-driveru-zusta...). zjistil jsem, že stačí dát restart PC (pomocí opičího trojhmatu :) a pak to často naběhne.

Jak se zdá,tak problém je v zapnutém agpgart při instalaci ovladačů. Na stránkách ATI se přímo píše: "If a Linux 2.6.11 or newer kernel was built with CONFIG_AGP
enabled, the kernel AGP frontend is required to load the fglrx kernel
module. To identify whether your kernel was built with CONFIG_AGP
enabled, look for CONFIG_AGP=y in the kernel config file, or if the
'agpgart' module is loaded."

Jenže nikde agpgart nemohu najít, i když při instalaci ovladače mi to nahlásilo že jej mám. Zkusil jsem dát příkaz "modprobe -r agpgart", ale dostal jsem hlášku "Module agpgart not found"

Ještě přikládám výpis hlášek z logu po jednom takovém nepovedeném "startu":
(EE) fglrx(0): Failed to initialize ASIC in kernel.
...
(II) fglrx(0): [pci] find AGP GART
(EE) fglrx(0): [agp] Failed to get AGP mode!
(EE) fglrx(0): cannot init AGP
...
(WW) fglrx(0): could not detect X server version (query_status=-1)
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available *
(WW) fglrx(0): ********************************************* *

Může mi někdo poradit co mám dělat
Mám OpenSuse 11.0, jádro 2.6.25.18-0.2-x86_64, Ati Catalist 8.12, Chipset nVidia nForce3